0

How do I format this field?

I've tried everything in the display as field, but nothing changes as to what is displayed.

Screen Shot 2021-03-26 at 10.06.25 PM

Screen Shot 2021-03-26 at 10.05.46 PM

16replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
    • Mr. K.
    • Mr_K
    • 1 yr ago
    • Reported - view

    I sure wish I could edit here. Show as, not display as.

    Like
    • Fred
    • Fred
    • 1 yr ago
    • Reported - view

    When you click on Show As it will take you to the Formula editing window. From there you can just select the field name you want to show, i.e. Customer.Name.

    Like
    • Mr. K.
    • Mr_K
    • 1 yr ago
    • Reported - view

    I'm saying that I have tried that. Seems that when the field is set to Show As Conbo Box, entering a formula in the More Options/Show as has no effect on what is displayed.

    Like
    • Fred
    • Fred
    • 1 yr ago
    • Reported - view

    I've never tried putting a formula in a Show As. I just use the field names that I want to show. I can do a concat of field names.

    Like
    • Mr. K.
    • Mr_K
    • 1 yr ago
    • Reported - view

    Anything entered into this field is a formula.Screen Shot 2021-03-27 at 3.43.52 PM

    Like
    • Fred
    • Fred
    • 1 yr ago
    • Reported - view

    That is confusing. Like I said earlier, it looks like a typical formula window, but if you just add the name of the field you want to show then it will just show that field. Select the field that has the data in your screenshot "Kari"  in it. Just the field name and nothing else. It will then show just data and not the Name and percentages.

    Of course, maybe I should ask what data are you trying to show here? What field are you trying to default to?

    Like
    • Mr. K.
    • Mr_K
    • 1 yr ago
    • Reported - view

    And I am saying I have done that and no change appears in the field display. It looks like this to begin:

    Screen Shot 2021-03-27 at 5.27.28 PM

     

    I open the editor window

    605ea28a6fc24a39989e7c4d

    I enter this in the Show as:

    Screen Shot 2021-03-27 at 5.50.39 PM

     

    I press OK and nothing changes in the display. It still looks like this:

    Screen Shot 2021-03-27 at 5.27.28 PM

    Like
    • Fred
    • Fred
    • 1 yr ago
    • Reported - view

    Since there is no error message, the field name is valid.

    I'm stumped. Maybe someone else has experienced something similar.

    Like
    • Mr. K.
    • Mr_K
    • 1 yr ago
    • Reported - view

    I'm leaning towards a bug or it can't be done. I plan to ask Tueday at the Open Office Zoom meeting.

    Like
  • "Show as" is indeed a formula field. But it has an effect on the "Popup" "Show as" option only - yep, two "Show as" fields on the same panel. If you select another option, then its content depends on the columns selected in "Edit columns". Those idiosyncrasies are what makes Ninox so lovely.

    Like
  • Yep I have had this issue in the past too wher my field name is '118 xxx etc')

    mainly got this error when i typed the field name!.

    so usually it menat i have to cancel - save - come out off the form.

    Go back in and pick the neame from the list (not type it )

    then quite often it accepts it!

    Like
    • Mr. K.
    • Mr_K
    • 1 yr ago
    • Reported - view

    Glad to know I am not alone. This is inconsistent with how Ninox works with other fields.

    Screen Shot 2021-03-28 at 7.56.45 AM

    Screen Shot 2021-03-28 at 7.57.49 AM

    Like
  • If you make the field, for instance, a Combo box, its content is determined by the columns selected in "Edit columns" since it is not a Popup. You can always add a "formula" column, and put anything to your liking in that formula.

    Like
    • Mr. K.
    • Mr_K
    • 1 yr ago
    • Reported - view

    Alain, I understand what you are saying. I will give that a try. Thanks

    Like
    • Mr. K.
    • Mr_K
    • 1 yr ago
    • Reported - view

    Got it working, thanks. I do think it would be better if Ninox didn't show or hinted that the Show as formulat filed did nothing for Combo Box view.

    Like
    • Mr. K.
    • Mr_K
    • 1 yr ago
    • Reported - view

    Again, if I could only edit my post to correct spelling. What a shame.

    Like
Like Follow
  • 1 yr agoLast active
  • 16Replies
  • 824Views