0

When you sum a column how can you set decimal place for the sum value

3 replies

null
    • visiolimaurizio
    • 3 yrs ago
    • Reported - view

    Check the fields they should be as numbers with 2 decimals. Otherwise use the  format function ... format(number,"0000,00")

     

    format( Number, Format ) converts a Number into a formatted text. As Format a Text is needed:

    0 represents a number or 0
    # represents a number that is diplayed only, if the number is big enough
    . represents the decimal separator (will be formatted according to the country, that means, in the UK and US it is shown as a floating point)
    , represents the grouping separator (will be formatted according to the country,that means, in the UK and US it is shown as a comma)

    Examples:

    format(42.5, "0") results in "42"
    format(42.5, "000") results in "042"
    format(42.5, "000.00") results in "042.50" format(42.5, "0.00") results in "42.50" format(42.5, "#,##0.00") results in "42.50" format(1042.5, "#,##0.00") results in "1,042.50"

    • Tom_Kerswill
    • 2 yrs ago
    • Reported - view

    This solution doesn't work for summing a column. If you set the field formula to:

    format(Amount, "0.00")

    Then the individual items look fine. But it's no longer possible to do a "Sum". Instead, the options are as if it's a text field - e.g. count, first, last, concatenate.

    • Fred
    • 2 yrs ago
    • Reported - view

    If it is a text field then you need another formula field that will convert it to a number. If you do a Edit Fields and see a T next to the filed then it is a text field. Create a new formula field, call it convert and put something like number('field name'). Now add this new field to your table view and you should be able to sum it.

Content aside

  • 2 yrs agoLast active
  • 3Replies
  • 430Views