0

Array trouble after update

I have some code that creates 2 arrays of records, which I then combine thus:-

array(thoseDirect, thoseDupes)

The combined array then gets used in a Dynamic Choice field. I would swear that when I implemented this some weeks ago, it was working perfectly (or I wouldn't have done it).

This afternoon I had occasion to use the db but noticed that those DC fields were empty. I had made NO changes to the code and was at a loss trying to figure why it now did not work.

In the end, I discovered that by instead using:-

array(thoseDirect, thoseDupes) order by fullUnit

it was working again. So the original code returned an empty array, whereas if first sorted by one of the fields, the correct array was returned.

Apart from being extremely bizarre behaviour, I'm convinced this is not how it was. I am now running Ninox (Mac) 3.7.3 which looks to be dated 8 Sept, so after I originally wrote the first code.

I cannot help but think this issue has been introduced by the recent Ninox update.

Anyone else noticed the latest Ninox not playing nice with arrays?

1reply Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
    • Fred
    • Fred
    • 4 mths ago
    • Reported - view

    I'm currently running 3.7.3 as well and I haven't noticed anything so far and I uses arrays in my formula everywhere in my main DB. What I don't do is use the array function, so I can't say if anything has changed since the upgrade.

    I'll tried a dynamic choice field being create by an array function

    let c := (select Table1);
    let d := (select Table4);
    array(c, d)
    

    and it worked for me. But I'm already in 3.7.3.

    Like
Like Follow
  • 4 mths agoLast active
  • 1Replies
  • 30Views
  • 2 Following