0

Share information between two tables

Hello

I have a formula that copies information from another table when the table name is same

let t := this; 
first((select AllTables)['Table Name' = t.'Table Name'].'Number23')

how to make it copy the information when the date matches in both tables? 

Elsewhere I use a table like this

let d := format(Date, "DD.MM.YY"); 
(select 'GM TABLE')[format(DATE, "DD.MM.YY") = d].number56

 

Regads 

4replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
    • Fred
    • Fred
    • 2 mths ago
    • Reported - view

    If the date field is in AllTables:

    first((select AllTables)[dateField = t.dateField and 'Table Name' = t.'Table Name'].'Number23')
    

    If the date field is in 'Table Name':

    first((select AllTables)['Table Name' = t.'Table Name' and 'Table Name'.datefield = t.datefield].'Number23')
    
    Like
    • Fred Thanks for the quick response

      I have the "Date" field in both places, but the formula doesn't work. I checked both formulas.  First one  no mistake but not work 

      first((select AllTables)[date = t.date and 'Table Name' = t.'Table Name'].''Number of chips 1 show')

      Second have a mistake

      Like
    • Fred
    • Fred
    • 2 mths ago
    • Reported - view
    ekalcasino777 said:
    I have the "Date" field in both places, but the formula doesn't work. I checked both formulas.  First one  no mistake but not work 

     I would check that there are records that meet the requirements that you set. To check you should try each parameter separately:

    first((select AllTables)['Table Name' = t.'Table Name'].'Number23')
    
    then
    
    first((select AllTables)[dateField = t.dateField].'Number23')
    
    

    If they both work, then you know that there is no record that matches both requirements.

     

    ekalcasino777 said:
    Second have a mistake

     So my first question is 'Table Name' a reference field or just a text field?

    Like
    • Fred it was my mistake. The date field was not filled in automatically. Today I started to do everything all over again and everything is fine.

          Thanks for your help

      Like
Like Follow
  • Status Answered
  • 2 mths agoLast active
  • 4Replies
  • 19Views
  • 2 Following