0

Dynamic Reports - my first attempt

Hi there,
Here I was thinking it would be straight forward.  I have a docx template and in Word I added

{d.'PROJECT TITLE'} 

as a data field (it's spelt correctly, all UPPER).  When I print or test print the {} is not replaced with the field contents.

My understanding is that Ninox see the {} and replaces it with the content of the matching field much like a regular report.

Clearly, I am missing something fundamental.  I am not trying custom JSON.  The report is so basic I assumed I would be on my way in no time...foolish me.

Where am I going wrong besides taking things for granted?

 

TIA

20 replies

null
    • Rafael Sanchis
    • Rafael_Sanchis
    • 10 mths ago
    • Reported - view

    I've been in the same problem for a long time.

      • Alan_Cooke
      • 10 mths ago
      • Reported - view

       Ah....so it might not be me right :-).

      • Sean
      • 10 mths ago
      • Reported - view

       Nope

      • Alan_Cooke
      • 10 mths ago
      • Reported - view

       Have you tried or would it help to create a formula field of the text field named d.ProjectTitle for example and simply add the braces to enclose the fieldname?  Weird idea I know but.....

      • Sean
      • 10 mths ago
      • Reported - view

       No, I haven’t tried it. I was just aware that others had tried it and found it difficult to work with. might have some pointers.

      • Alan_Cooke
      • 10 mths ago
      • Reported - view

       I tried - used {d.PROJECT_TITLE} as a field name and it don't work.  Has Ninox Support offered any solutions?

      • Sean
      • 10 mths ago
      • Reported - view

       The link attached to my "Nope" has more information.

    • Ninox partner
    • RoSoft_Steven.1
    • 10 mths ago
    • Reported - view

    Hello,

    Carbone is very strict with placeholders:

    see manual here or here.

    Hope this helps.

    • Mel_Charles
    • 10 mths ago
    • Reported - view

    I had a stored database with some dynamic forms that all worked (albeit there was a few issues with child sub forms in terms of picking up all the relevant lines). I'm on web cloud version 

    I just reloaded this database back in and tested the dynamic output ..... err it ain't no longer working folks. I know they worked, cos I used it for a couple of months but I felt the dynamics forms layout/setup to much of a faff and at the time there were several complaints on the forum that users forms stopped working without any apparent reason. Also it would Ninox appear to put a limit of 500 prints in a given month which might have some bearing on that tho! 

    Sounds like it no longer talks to current version or something. Best report to support!

    and it should really be this simple to specify the fields

    • Fred
    • 10 mths ago
    • Reported - view

    You got me interested in trying dynamic printing and created a file with:

    {d.Country}

    And I got:

    test1

    The docs don't talk about how to handle spaces in names. Or is it saying that you can't. So you can't put ' ' around a field name like you do in Ninox. If that is true then you will have to create print fields that don't have spaces.

      • Ninox partner
      • RoSoft_Steven.1
      • 10 mths ago
      • Reported - view

       yes, no spaces. See my post above for the links

      • Alan_Cooke
      • 10 mths ago
      • Reported - view

       That's what I have figured - so all the fields that one would like to print........dynamically......talk about future planning.......needs to be CamelCase or underscored which visually is C**pCase :-) or worse a plethora of formula fields.  Messy to say the least.  When dynamic was mentioned I though WOW!  Not so excited about that now.

    • Alan_Cooke
    • 10 mths ago
    • Reported - view

    Sounds like it more trouble than it's worth frankly.  Boggles my mind as to why Ninox appears to be reluctant to do anything about providing a worthy print engine to their otherwise great product.

    • Mel_Charles
    • 10 mths ago
    • Reported - view

    Set one up exactly with a table and filed name excatly as on Ninox own screen shot above

    even with a few camel variations

    Guess which one worked ?

    Name of Company {d.customers.company}

    Name of Company {d.Customers.company}

    Name of Company {d.customers.Company}

    Name of Company {d.Customers.Company}

    Name of Company {d.Company}

    Thats right - None of them !

    logged out , closed down etc

    went and fetched some fish and chips

    logged back in..... Nothing !

     

    I think that is why I abandoned it some months back cos only worked some of the time.

      • Ninox partner
      • RoSoft_Steven.1
      • 10 mths ago
      • Reported - view

       I guess you need to re-upload your word-template in Ninox printeditor to make it active?

      They've also changed the cloud version to 3.9.0 this morning, maybe it's a glitch?

      • Fred
      • 10 mths ago
      • Reported - view

      I tried updating a template and it gave me an error. So it looks like there could be some issues with v3.9.

      • Mel_Charles
      • 10 mths ago
      • Reported - view

       reloaded it umpteen times!....😉

    • Fred
    • 10 mths ago
    • Reported - view

    It seems to take the server about 3 - 8 minutes to create a test print of 1 record. The fewer the records in the table the faster the test print of only 1 record. Some tables don't even generate a test print at all. Still can't figure that one out.

    But do others also have the same issue or is this a feature?

      • Mel_Charles
      • 10 mths ago
      • Reported - view

       Yes carbone or whatever very SLooooow to generate the reports.

      I deffo would like to use this feature but the moment I can't put up with the in consistency for now.

      It's funny - I have used many database related software for too many years to divulge and yet all of them had a decent inbuilt report/print generator build in.

    • Alan_Cooke
    • 10 mths ago
    • Reported - view

    On the off chance I tested my dynamic report a few moments ago.  It seems to be working now so I suspect Ninox had an issue their side.

Content aside

  • Status Answered
  • 10 mths agoLast active
  • 20Replies
  • 237Views
  • 6 Following