0

Bug report

Lettle bug to report.

There is a difference in view from Ninox app and Ninox Cloud for the same form.

Below two screenshot on wich you can view that the same record and value, in Cloud version the number -80,50 is reported as -80,85000000000002

No formatting has applied.

Ninox APP v. 3.2

Screen from WEB CloudScreen from APP

4 replies

null
    • Admin.5
    • 2 yrs ago
    • Reported - view

    try to check [field] = -80,85 if that will return different results in app and cloud then it is not just about formatting but reading / calculating actual data as well

    • Rigas_Rimini_ONLUS
    • 2 yrs ago
    • Reported - view

    Hi. Check it better.
    The value is the result of formula "sum(831,60) - sum(750,75)", so the correct result should be as -80,85.
    The cloud version seems to wrong calculate the formula and give as result "-80,85000000000002".

    Moreover I apply the "#,##.00 €" format to the table field, but in the cloud version that format is not applied.
    In the iMac App they works both the calculate and the format well.

    Schermata 2021-03-29 alle 10.34.18

    • Admin.5
    • 2 yrs ago
    • Reported - view

    I had similar problem when trying to sum up field values in subtable records. I think it happened only when much records were being summed up. Didn't check nor remember which apps had this issue though. Definitely a bug

    • Fred
    • 2 yrs ago
    • Reported - view

    Something similar happened to me. On the app I have many forumal fields that rounds a division calculation to 3 spots then multiply by 100 and they shows up fine. When I moved it to the web, a few of them show up with a long string of 9's or 0's. I submitted a ticket and they told me to round again at the final step of the formula. So basically a work around not a fix. 

     

    If you haven't you should report it to Ninox so they get that that should fix it and not tell people how to work around it. 

Content aside

  • 2 yrs agoLast active
  • 4Replies
  • 442Views